7 posts / 0 new
Last post
mmajor
How to reprovision milli device?

Following the instructions for provisioning here (https://developer.itron.com/milli-developer-kit-setup-and-provisioning), it just says "and follow the instructions as described in the application. [Milli Provisioning App]" 

When I initially provisioned the boards, I selected the Country Code and left Network Id on default (1710 PROD), because the instructions did not specify to change the network ID from default.

Later in the reference Application instructions, I am getting BAD REQUEST when attempting to Ping the Milli device.  I then noticed that in the starfish studio device info it has ""targetNetworkId": "1711""

So, I re-ran the provision app attempting to provision to that network ID, but now it does not detect the Milli5 board.

 

Am I correct to conclude that I should have provisioned them as 1711 (STAGING) to match what's shown in the starfish studio?  If so, how can I get the provision process to run again correctly?

 

Resolution summary:

network ID needed to be set to 1711 (Starfish Staging)

The reason that the provisioning application won't recognize the milli is that I had already changed the running image to the standard operating image.  It needed to be changed back to the self-test image to allow the provisioning app to run again.

Steps taken to re-provision the milli 5:

1. "sio_load.exe -i <COM port to which the Milli Shield is connected> -b -3"

2. Ran provisioning application, selected region (US) and network 1711.

3. Then followed steps for firmware upgrade starting with:  "sio_load.exe -i <COMport> -f -3 <milliImageFilename.bin>" and reselecting the standard operating image.

tthayer
Re: Network ID

Yes, network ID needs to be set to 1711 (Starfish Staging)

mplisik
The reason that the

The reason that the provisioning application won't recognize the milli is that the running image is the standard operating image.  When you first received the unit, it was running an image that is used for configuration.  There is a work-around.

Have a look at the following page:   https://developer.itron.com/how-update-firmware-images

If you have not already done so, you should have updated the images.  I suspect that you have, since you are now (probably) running the standard operating image.  The final instruction on this page (number 13) says to issue the following command:  atb 1.2.1000.  The atb command is used to set the next boot image, which in this case is the standard operating image. 

In order to re-provision your milli you need to get to what is being described on this page as the self test image.  You can do this by connecting the UARt to the serial port of your computer, as described earlier, but this time, type the following command at the prompt: sio_load.exe -i <COM port to which the Milli Shield is connected> -b-3 

You will once again be prompted to restart your milli.  When sio_load says that you have finished successfully, if you restart you will be running the firmware image that the provisioning app expects to work with.

If you would be so kind, please post your progress here, and I'll provide further help as necessary.

mmajor
Thanks, that worked!  Now I

Thanks, that worked!  Now I get back "SdkCallback                         | INFO  | ***Payload As String: <SSNI MilliNIC CoAP server 1.0>" in response to a ping.  So, I can continue past this.   Both of the Milli5s we have are responding to pings now.

Added the steps in the original post.  I did need to add a space between the "b" and "3" command line options for sio_load.

 

As a separate minor question:  the Windows CoAP client page has a link "Get the Windows CoAP Client Application from DocumentCenter ", but then in Document Center, all I can find is a link back to the webpage I just came from -- with the link to the Document Center.   I can't find where to get those files.

tthayer
Where to find Windows CoAP Client and Server in DocumentCenter

Select either Base Material or IOT in the Area of Interest Drop Down. Then in the document tree Reference Applications->Windows CoAP Tools->App and Source.  Note: you must be logged in to the Developer Portal to access and download the applications.

Jhamilton1184
I had the same problem, but I

I had the same problem, but I can't update the firmware I using:

sio_load.exe -i COM7 -f -3 milli.sfl_.prod_sig.01.02.1000.112738.bin

but it is saying cannot open image file

 

what do I do?

 

pkatiyar
Re: Reprovision

Hi Jarryd,

Are you trying to update for the firmware for the first time or re-provision the device. Make sure that the image file name should be in the same directory from where you are executing sio_load & file name should match.  Let us know if you still face the issue.

Thanks