3 posts / 0 new
Last post
getting error "fatal error: sys/queue.h: No such file or directory"
I am using a SparkFun RedBoard as my Arduino board, however error I get from Arduino IDE is Arduino\libraries\ssni_coap_server/coap_rsp_msg.h:33:23: fatal error: sys/queue.h: No such file or directory #include Also, cloned the GitHub Code today; tried on Linux, Mac and Windows 10, getting the same error - Using Arduino IDE 1.8.4 on Windows and 1.8.5 on Mac.
SilverSpring has not done any

SilverSpring has not done any testing with that particular board. I would recommend using an M0 Pro or an M0.  Those have been thoroughly tested.

Also, please make sure that you have included all required libraries, per the dev portal documentation.

Re:SilverSpring has not done any

Also ensure you have download the folder ssni_coap_server from github and copied to your Arduino libraries C:\Users\<user>\Documents\Arduino\libraries Note: Replace <user> with your username

Make sure sys/queue.h file are included in same directory.